Cisco Network Router 명령어 정리

Cisco Router 명령어 정리
  설정 프롬프트 설정 명령 보기 프롬프트 보기 명령
라우터 이름 설정 Router# conf t
Router(config)# hostname R4
관리 비밀번호 설정 Router(config)# enable secret cisco
enable password cisco
텔넷 비밀번호 설정 Router(config)# line vty 0 4
Router(config-line)# login
Router(config-line)# password cisco
텔넷 연결 세션 보기 Router# show session
세션 종료 Router# disconnect
라우터 IP 설정 Router# conf t
Router(config)# interface fa 0/0
Router(config-if)# ip address 150.10.1.1 255.255.255.0
포트 동작 시키기 Router(config-if)# no shutdown
VLAN 1 및 IP 설정 Router(config) interface fastEthernet 0/0.1
Router(config-subif) encapsulation dot1Q 1 native
Router(config-subif) ip address 10.10.10.1 255.255.255.0
VLAN 2 및 IP 설정 Router(config) interface fastEthernet 0/0.2 (0/0.2에서 2는 별로 의미없는 것 같고)
Router(config-subif) encapsulation dot1Q 2 (dot1Q 2에서 2가 vlan2를 뜻한다)
Router(config-subif) ip address 10.10.11.1 255.255.255.0
IPX 동작 시키기 Router# conf t
Router(config)# ipx routing
interface fa 0/0
Router(config-if)# ipx network 1
IGRP 라우팅 프로토콜 Router(config)# router igrp 200
Router(config-router)# network 172.16.0.0 (network로 인접 fa,s 등 모두 입력해준다.)
Router(config-router)# network 150.100.0.0
Router(config-router)# no network 150.100.0.0
NVRAM으로 저장 Router# write memory
copy running-config startup-config
  설정 프롬프트 설정 명령 보기 프롬프트 보기 명령
스태틱 라우팅 Router(config)# ip route 150.150.0.0 255.255.0.0 203.210.100.1
Router(config)# ip route 150.150.0.0 255.255.0.0 serial 0
디폴트 라우트 Router(config)# ip default-network 203.240.10.0
스태틱으로 디폴트 구현 Router(config)# ip route 0.0.0.0 0.0.0.0 203.240.10.1
텔넷 유저까지 설정 Router(config)# line vty 0 4
Router(config-line)# login local
Router(config-line)# exit
Router(config)# username ccna password cisco
AUX포트 비밀번호 설정 Router(config)# line con 0
(10분 30초) Router(config-line)# exec-timeout 10 30
타임아웃 안걸기 Router(config-line)# no exec-timeout
(주의!! 콘솔 입력 못하게) Router(config-line)# no exec
RIP 라우팅 프로토콜 Router(config)# router rip Router# show run
RIP 라우팅 시작 Router(config-router)# network 150.150.100.0 Router# show ip protocol
Router# show ip route
RIP 라우팅 제거 Router(config)# no router rip
RIP 디버깅 시작 Router# debug ip rip
RIP 디버깅 종료 Router# no debug all
Router# undebug all
IGRP Bandwidth설정 Router(config)# int s 0
Router(config-if)# bandwidth 56
IGRP 설정 Router(config)# router igrp 200(AS번호)
Router(config-router)# network 150.140.100.0 Router# undebug all
IGRP 지우기 Router(config)# no router igrp
IGRP 최대 홉 변경(옵션) Router(config)# router igrp 200
Router(config-router)# metric maximum-hops 255(최대)
Passive Interface설정 Router(config-router)# passive interface fa 0/0
IGRP 디버깅 시작 Router# debug ip igrp transactions
IGRP 디버깅 종료 Router# no debug all
Router# undebug all
OSPF 설정 Router(config)# router ospf 100 Router# show ip ospf interface
Router(config-router)# network 172.16.10.0 0.0.0.255 area 0 Router# show ip ospf neighbor
Router(config-router)# network 192.168.12.0 0.0.0.15 area 0
OSPF 디버깅 시작 Router# debug ip ospf events
Router# debug ip ospf adj
OSPF 디버깅 종료 Router# undebug all
IPX 라우팅 정의 Router(config)# ipx routing [4.4.4]
Router(config)# int fa 0/0
(encap은 한쪽만 설정) Router(config-if)# ipx network 1818 encapsulation sap
Router(config)# int s 2/0
Router(config-if)# ipx network 1400
IPX 상태 보기 Router# show ipx interface fa 0/0
IPX 라우팅 테이블 보기 Router# show ipx route
파일서버 연결 상태 보기 Router# show ipx server
기본 ACL 목록 등록 Router(config)# access-list 1 permit 210.240.100.0 0.0.255.255
Router(config)# access-list 1 deny 210.240.100.5
Router(config)# access-list 1 permit any
인터페이스에 ACL적용 Router(config)# int fa 0/0
Router(config-if)# ip access-group 1 in
Router(config-if)# ip access-group 1 out
ACL 적용 상태 보기 Router# show ip interface fa 0/0
ACL 목록 보기 Router# show ip access-lists
텔넷포트에 ACL 적용 Router(config)# line vty 0 4
Router(config-line)# access-class 1 in
확장 ACL 목록 등록 Router(config)# access-list 101 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
Router(config)# access-list 101 permit ip any any
Router(config)# access-list 101 permit ip 0.0.0.0 255.255.255.255 131.108.5.17 0.0.0.0
Router(config)# access-list 101 permit ip any 131.108.5.17 0.0.0.0
ACK나 RST bit가 set되면 Router(config)# access-list 104 permit tcp any 128.88.0.0 0.0.255.255 established
텔넷 막는 ACL 설정 Router(config)# access-list 101 deny tcp 150.100.2.0 0.0.0.255 150.100.1.0 0.0.0.255 eq telnet
FTP막는 ACL 설정 Router(config)# access-list 101 deny tcp 150.100.2.0 0.0.0.255 150.100.1.0 0.0.0.255 eq ftp-data
Router(config)# access-list 101 deny tcp 150.100.2.0 0.0.0.255 150.100.1.0 0.0.0.255 eq ftp
HSRP 그룹 및 가상 IP설정 Router(config-if)# standby 1 ip 172.70.100.1 Router# show standby
우선순위(수치큰게 active) Router(config-if)# standby 1 priority 105
Active 복귀시간 지정 Router(config-if)# standby 1 preempt delay 5
IF죽으면 우선순위10다운 Router(config-if)# standby 1 track serial2 10
Active 변경 시간 지정 Router(config-if)# standby 1 timers 3 10 (3초마다 확인해서 10초이내 대답 없으면 Active됨)
디버깅 설정 Router# debug standby
디버깅 해제 Router# undebug all
IP NAT 설정 Router(config)# ip nat pool ccie 210.98.100.2 210.98.100.254 netmask 255.255.255.0
NAT 설정 Router(config)# ip nat inside source list 1 pool ccie (inside측 source주소가 ACL 1에 걸리면 ccie Pool 적용)
NAT 고정으로 설정 Router(config)# ip nat inside source static 10.1.1.100 210.98.100.100
ACL로 inside local 지정 Router(config)# access-list 1 permit 10.1.1.0 0.0.0.255
Inside Local로 IF설정 Router(config)# int fa 0/0
Router(config-if)# ip nat inside
Inside Global로 IF설정 Router(config)# int s 2
Router(config-if)# ip nat outside
NAT 동작 확인 Router# show ip nat translations
디버깅 켜기 Router# debug ip nat
디버깅 끄기 Router# undebug all
  설정 프롬프트 설정 명령 보기 프롬프트 보기 명령
Setup Mode 가기 Router# setup
User Mode에서 Router> enable
Privileged Mode에서 Router# config terminal
Configuration Mode에서 Router(config)# exit
다시 User Mode로 가기 Router# disable
라우팅 테이블 Router# show ip route
라우터 기본 정보 Router# show version
모든 인터페이스 정보 Router# show interface
이더넷 인터페이스 정보 Router# show interface ethernet 0
시리얼 인터페이스 정보 Router# show interface serial 0
현재 구성 파일 Router# show running-config
Router# write terminal
NVRAM 백업 구성 파일 Router# show startup-config
Router# show config
플래쉬 메모리 Router# show flash
라우터 동작 상태 Router# show processes cpu
배너 입력하기 Router(config)# banner motd #
Router(config)# banner motd # This is end #
인터페이스 설명 Router(config)# int fa 0/0
Router(config-if)# description Text
Secondary IP 설정 Router(confug-if)# ip address 203.240.150.1 secondary
Back-to-Back 구성 Router(config)# int s 0 Router# show controller serial 0
(DCE쪽에서 설정) Router(config-if)# clockrate 56000
  설정 프롬프트 설정 명령 보기 프롬프트 보기 명령
기록 명령 개수 설정 Router# terminal history size 30
서브넷 맨앞 주소 사용 Router(config)# ip subnet-zero
DNS설정 Router(config)# ip name-server 168.126.63.1
TFTP서버 돌리기 Router(config)# tftp-server flash c800-g3-mw.120-3.T1
IOS TFTP에서 가져오기 Router# copy tftp flash
라우터 전체 CDP 금지 Router(config)# no cdp run
라우터 전체 CDP 동작 Router(config)# cdp run
특정 IF의 CDP 금지 Router(config)# int serial 0/0
Router(config-if)# no cdp run
특정 IF의 CDP 금지 Router(config-if)# cdp run
CDP 동작 상태 보기 Router# show cdp
연결된 시스코 장비 보기 Router# show cdp neighbors
연결된 시스코장비 자세히 Router# show cdp neighbors detail
Router# show cdp entry *
CDP 트래픽 보기 Router# show cdp traffic
단순형 핑 Router# ping 150.10.1.1
확장형 핑 Router# ping
Trace Router# trace 150.10.1.1
DHCP 사용 Router(config)# service dhcp
Router(config)# ip dhcp pool ccna
Router(dhcp-config)# network 210.240.10.0 255.255.255.0
Router(dhcp-config)# default-router 210.240.10.1
DHCP Pool 할당 제외 Router(config)# ip dhcp excluded-address 210.240.10.1
DHCP 할당 내역 보기 Router# show ip dhcp binding
라우터의 DHCP 상태 보기 Router# show ip dhcp server statistics

Cisco Network Router 명령어 정리”에 대한 답글 1개

  1. 최정운 2019년 10월 18일 / 6:40 am

    안녕하세요 네트워크 및 개발 정기기운용기능사 준비하는 학생입니다.
    이거 프린트해서 공부할때 써도 될까요? 너무 정리를 잘해놓으셧습니다 .
    괜찮으시면 프린터 해도 될련지요…..

    좋아요

댓글 남기기